uragan 30

Forums PCP Airguns uragan 30

  • Views : 367
  • Link

    samie15
    Participant
    Member

    uragan 30 cal sudden loss of power over 100 fps 

    Link

    JCD
    Participant
    Member

    Breech o-ring?

    Link

    vmaxpro
    Participant
    Member

    Need more details, could be a number of things.

    Link

    samie15
    Participant
    Member

     hi its not a breach seal . i got the gun brand new from talon tunes and he had the gun shooting at 928fps and well dialed in after several months i noticed the power dropped down to 812 fps this is with a 50 gn jsb pellet  it seams to me like a reg problem and i did read that someone else had a simular issue i dont know how they made out  yet

    Link

    0akhonor
    Participant
    Member

    Charlie Frear is a good source for these questions. He shared that the Reg question wasn't with the .30's but that other calibers might be susceptible.Hang in there, and maybe give Charlie a call? He's a good cat, knows his product .

    I'm following this thread, see what you learn- so good (great ) luck to you!

     

    Link

    vmaxpro
    Participant
    Member

    Yea its kind of a pain they dont come with a reg pressure gage. What pressure is in the bottle? Shoot it down to 160 bar over the chrono and check back in.

    Link

    vmaxpro
    Participant
    Member

    Also, quick easy checks is make sure the hst adjuster didnt come loose. A 1/4 turn is huge on these guns. 

    Link

    Odoyle
    Participant
    Member

    vmaxpro

    Also, quick easy checks is make sure the hst adjuster didnt come loose. A 1/4 turn is huge on these guns. 

    Sounds totally reasonable! Assuming you are using the OEM hammer spring adjuster and not an aftermarket one. If not put back the factory adjuster.

    Also inspect condition of the hammer spring and flip it around see if that helps some.

    Link

    zx10wall
    Participant
    Member

    I’ve seen a few Uragán have their barrels not fully secured and “slid” forward. This effect the transfer port alignment and could lower velocity if poor alignment is present. 

    Link

    vmaxpro
    Participant
    Member

    zx10wall

    I’ve seen a few Uragán have their barrels not fully secured and “slid” forward. This effect the transfer port alignment and could lower velocity if poor alignment is present. 

    Very well possible as well. 

    Link

    samie15
    Participant
    Member

    i did check that and all was good . i also checked the hammer spring and reversed it just incase. now waiting for a new huma reg that is coming today so i should have a answer tonight if in fact it is a reg problem. 

    Link

    Ozell
    Participant
    Member

    I have had that same problem and yes it was a 30 Caliber Uragan, I brought mine's from Charlie Fear and it turn out it was the Factory Regulator some with the o rings to small

    any way i had him to put in a Huma and it seen to work. hope this help.

    Link

    samie15
    Participant
    Member

    thanks for the input i am waiting for ups today for the new huma reg and i hope like you that this is the answer i have checked everything else.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.