Strange issue

Forums PCP Airguns Strange issue

  • Views : 1360
  • Link

    Siscakidd
    Participant
    Member

    I purchased a 22 caliber Kral breaker from pyramid air and shortly after had to  send it back for an air leak,once I got it back I shot it for a couple weeks and then the valve broke so rather than send it back to PA I decided to send it to a real tuner to have it gone over,now before it went in it was a tack driver I mean same hole over and over at 35 yds would even say it out shot my wildcat at closer ranges,but since being tuned i get it zeroed and after four five shots it starts to walk left in a straight line,bring it back to zero and take 4-5 shots ad it starts to wonder right….I tried ever thing I can think of,different scope,cleaning the barrel,clipping the baffles, 4-5 different pellets no matter what it will not stay zeroed. Can this be caused by a bad tune?this is out of my experience level, anyone have any ideas?

     

    Link

    Deleted Account

    It sounds like the barrel band being connected to the air tube and barrel, causes your barrel to move ever so slightly when the tube contracts and expands from changing pressure?  I’m not familiar with the kral guns but if you can remove the barrel band and shoot it would eliminate that possibility.

    Link

    Siscakidd
    Participant
    Member

    Yeah ,the way it’s set up the barrel band has an O ring in it and it makes contact with the shroud and the end of air tube not the air cylinder itself,really frustrated with this,was such a good shooter before 

    Link

    thammer
    Participant
    Member

    What pellet was the most accurate before the tune? Are you shooting heavier or lighter weight pellets?

    Link

    Siscakidd
    Participant
    Member

    I have tried 4 different pellets,all that shot well before the work was done.and I will get 4-5  shots that you can cover with a dime then it moves out a ring then 2  then 6-8 inch’s from the original POI !?!?

    Link

    thammer
    Participant
    Member

    I was. That’s weird, never seen that before. 

    Link

    thammer
    Participant
    Member

    “Siscakidd”I have tried 4 different pellets,all that shot well before the work was done.and I will get 4-5  shots that you can cover with a dime then it moves out a ring then 2  then 6-8 inch’s from the original POI !?!?

    
I’ll send you a shipping label. Get it back to me and I’ll make it right. Not sure why it’s doing that but I’ll find out and correct it. 

    Link

    Siscakidd
    Participant
    Member

    “thammer”

    “Siscakidd”I have tried 4 different pellets,all that shot well before the work was done.and I will get 4-5  shots that you can cover with a dime then it moves out a ring then 2  then 6-8 inch’s from the original POI !?!?

    
I’ll send you a shipping label. Get it back to me and I’ll make it right. Not sure why it’s doing that but I’ll find out and correct it. 

    
Wow! Intentionally did not mention the name of the tuner till I had a chance to call you on Monday,but thanks for chiming in here,was hoping it was something that you could talk me through but I will send it back back to you….thanks Troy

    Link

    thammer
    Participant
    Member

    “Siscakidd”

    “thammer”

    “Siscakidd”I have tried 4 different pellets,all that shot well before the work was done.and I will get 4-5  shots that you can cover with a dime then it moves out a ring then 2  then 6-8 inch’s from the original POI !?!?

    
I’ll send you a shipping label. Get it back to me and I’ll make it right. Not sure why it’s doing that but I’ll find out and correct it. 

    
Wow! Intentionally did not mention the name of the tuner till I had a chance to call you on Monday,but thanks for chiming in here,was hoping it was something that you could talk me through but I will send it back back to you….thanks Troy

    
I guarantee my work so if it’s not doing what’s it’s supposed to I’ll take care of it. 

    Link

    NMshooter
    Participant
    Member

    Might want to just check all your screws. Just happened to Michael. 

    Link

    Siscakidd
    Participant
    Member

    Link

    Siscakidd
    Participant
    Member

    I have got 20 targets that look like the one below

    Link

    Siscakidd
    Participant
    Member

    Link

    Siscakidd
    Participant
    Member

    The three shots that are not on target are the last three shots before I gave up for the day

    Link

    Crusher
    Participant
    Member

    Are you sure it isn’t something going on with the scope? Just asking. Maybe try a different scope and see if something maybe came loose inside?

    Crusher
     

    Link

    Siscakidd
    Participant
    Member

    I mentioned that in my first post ,tried a different scope…first thing that crossed my mind 

    Link

    Siscakidd
    Participant
    Member

    Don’t know why the picture is not staying?

    Link

    Siscakidd
    Participant
    Member

    Link

    Hynzie
    Participant
    Member

    “NMshooter”Might want to just check all your screws. Just happened to Michael. 

    
exzactly

    Link

    Siscakidd
    Participant
    Member

    I checked everything,cleaned the barrel,checked the screws,changed the scope,tried different pelllets 14gr 15gr 16gr 18gr ,checked the baffles for clipping,checked the barrel band

Viewing 20 posts - 1 through 20 (of 22 total)

You must be logged in to reply to this topic.