Impact owners…

Forums PCP Airguns Impact owners…

  • Views : 1009
  • Link

    jfrench64
    Participant
    Member

    You stated the gun is louder .  that's a pretty good indication something blew . see if this center pin is flush ,if it's sticking out it blew.   I felt air blow on my face every shot when mine blew thow . 

    Link

    DrOcean
    Participant
    Member

    jfrench64

    You stated the gun is louder .  that's a pretty good indication something blew . see if this center pin is flush ,if it's sticking out it blew.   I felt air blow on my face every shot when mine blew thow . 

    The valve seat is flush. I don’t feel air. It doesn’t seem like something blew either (although it may have). It feels like it’s not tuned in harmony. Lil louder n lil more recoil. It’s done it before. Last time I completely retuned it and it was great. Not it seems out of tune again based on feel and sound. The chrony says it’s fine. But something shifted. Not sure what. Thanks for the suggestion though.

    Link

    DrOcean
    Participant
    Member

    Azycray

    Put an infra red night vision security camera on the rifle and see what Gremlins are messing with it in the middle of the night.

    I know right! This seems to be the most likey explanation even though not possible (that I know of anyway) lol. It’s terribly frustrating. I’ll get to tinkering with it as soon as I can. I’m currently adding on to an old house and refurbishing it. So my week days are fairly busy. I bet it’s those pesky underpants gnomes. They need orings to spruce up their elastic waist bands.

    Link

    heavy-impact
    Participant
    Member

    Have you disassembled the shroud/air stripper/ suppressor to check for problems?

    Link

    DrOcean
    Participant
    Member

    No clipping. Valve seat good. Probe n probe block tight. Barrel grub tight. The orings in/on the barrel housing ok (breech, in past breech, around tp). Cleaned barrel. Hopefully that’s it. I really think something is just slightly off. Maybe something wearing in? Valve stop? Reg? Valve? Hammer? Idk. Spend a crazy amount of time getting it into perfect harmony and it doesn’t stay for long. Tells me something is creeping (unless it was just a dirty barrel). But according to so many long time FX owners after you clean the barrel it needs 30-150 shots through it before it shoots great again. And then it’s good for a few thousand before it needs it again cuz the barrel is so polished. So I don’t expect this to be the issue. But hey…maybe. I kinda hope so. Again. I don’t think something is crazy wrong with the gun. It’s almost certainly something simple (did u check it for gas??? 🤔😂) that I just don’t have the experience to diagnose or know to check for. If the barrel cleaning doesn’t sort it I’ll take this opportunity to crank her up n try a hot tune. If no go I’ll try to find this tune again. If no go then I’ll send her back n let a professional find it. I hate to do that. Waste of time n money. It’d be way cooler if an FX guru lived nearby…again…NETX…pm me if u exist! 

    Link

    DrOcean
    Participant
    Member

    Interesting development. I couldn’t find anything wrong. Cleaned barrel n put back together. Chrony went from 860fps to 840 in same settings (hst A). Put hst on 5 n got 850. Groups still over 1” at 50 for both. Moved to max n barely loosened valve like 1/8 turn. Back at 860 n shooting 1/2” at 50. Once the barrel is re-seasoned from the cleaning I bet it’s back to 1/4”. So who in the hell knows why this all happened. For now it sounds n feels right and is shooting well. Seriously scratching my head. 

    Link

    Drumsnguns
    Participant
    Member

    Sounds like the problem I was having …turned out to be a bum scope….replacement scope on warranty and now shooting consistently one hole at 50 y

    Swap scopes if you can and see if there's a difference.

     

    KP/NC

    Link

    jclee
    Participant
    Member

    you got a bubble level on your gun. maybe it was canted?

    Link

    Elbowgrease
    Participant
    Member

    Before tearing anything down check the scope. Put a different one on the impact and have at it. Also do you use an anti-cant bubble/level. If canted to much it could cause issues. The canting is jut a thought. Defiantly check the scope. High end scopes can go south also.  

    Link

    DrOcean
    Participant
    Member

    I’ve got the Vortex bubble on my scope, so cant shouldn’t be the issue, but good thinking in that anyway guys. I suppose it COULD be the scope, but I wouldn’t think so. If she starts acting up again I’ll definitely check that first thing. After a good cleaning she’s shooting well again. However I still can’t explain why it dropped 20fps after a barrel scrub. I thought maybe my hst screw had walked back on me from true max. It has not. So still scratching my head on that one. But house sparrows are currently unsafe again out to about 120yds, so for now I’m just going to cross my fingers and toes n hope it stays put. It has for the past week. Thanks for all the help. 

    Link

    Drumsnguns
    Participant
    Member

    DrOcean,

    I had the same exact problem. Impact would shoot lights out one day and then the next time I picked it up it would be shooting way right, left ,high or low. Then it got to where I'd zero it in dead nuts and then the very next target was off.

    So I slapped another scope on her and …..Voila. 

    My scope is an Athlon Athlon. I sent it to them and had an new scope in hand in like three days. Works great now with no POI shift.

     

    Check your scope

    KP/NC

Viewing 11 posts - 21 through 31 (of 31 total)

You must be logged in to reply to this topic.