Huntsman Regal XL PROBLEM

Forums PCP Airguns Huntsman Regal XL PROBLEM

  • Views : 438
  • Link

    npetro
    Participant
    Member

    My Hunttsman Regal in .177

    I have shot 4500 pellets through my regal and all was great until about the last 500 pellets.  I noticed a drop in velocity so today I ran it through a chronograph and noticed a BIG drop in velocity.  When new it was in mid high 800’s range. Pellets I’m using are JSB 10.34 grain EXACT

    These are my current numbers:
    Fill @ 220 bar:  shot 1 is 752fps. Shot 2 753. Shot 15 744

    Fill @ 240 bar:  shot 1 is 727 fps. Shot 2 724. Shot 15 744

    I did try to adjust the hammerspring via rear hole by the safety block.  Did get it to 850 range but it did not hold. Now it won’t cock or fire.  

    Anyone out out there in AGN Land have any similar problems? Or ideas on how to fix?

    Link

    D-RIG
    Spectator
    Spectator

    Did you remember to tighten the set screw thats in front of the trigger ,

     

    Link

    willy
    Participant
    Member

    This is sad news” did ya try backing the screw back out a few turns to to see if it would lock up again?

    Link

    npetro
    Participant
    Member

    I did tighten it also the probe o ring is good with no leaks.  Funny thing is the 3mm hex that I used ended up getting stuck in the rear adjustment hole (the hole right behind the safety block). With some pressure I was able to get the wrench out   Now when I cock the bolt it will not fire

    Link

    D-RIG
    Spectator
    Spectator

    Did you try to adjust the trigger at any point to make it lighter 
    too light of a trigger will cause the sear not to engage . 

    Link

    npetro
    Participant
    Member

    I backed it up quite a few turns same issue as well as tightened it up. I’m scratching my head on this one.  At first Adjustment I was able to regain the velocity to about 830 FPS, but unfortunately I made another slight adjustment on the screw (1/4 turn) CW and it went back to mid 700’s. Then the problem with it not being able to fire occurred

    Link

    npetro
    Participant
    Member

    No trigger work done I left it as is from factory

    Link

    D-RIG
    Spectator
    Spectator

    were you ever shooting wadcutters with the magazine and had them 
    not load I’ve had this happen and the pellets will drop through the actuator 
    bar and fall into where the hammer is and not allow the hammer to strike 
    the valve as hard . Also to much hammer strike will eventually hurt the FPS
    and you will loose speed 

    Link

    npetro
    Participant
    Member

    I shot a tin of wad cutters to break the barrel in when brand new. After that I only shot JSB Exact 10.34 grain   I chrony’d it with the JSB back then and it held consistent 840-860 FPS

    Link

    bzizzi373
    Participant
    Member

    Replace your transfer port seals, two small o rings. 

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.