Become an AGN forum member to be included in our multi-thousand dollar Monthly Airgun Giveaways! Winning is as easy as picking a number, no strings attached! This is our way of thanking you for being a part of the worlds biggest airgun forum. Yours truly, Michael Wendt - Owner.
Join HERE

UnfortunateCookie

Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Views :
  • Link

    UnfortunateCookie
    Participant
    Member
    France
    Accuracy: +0

    Never, ever do PayPal friend&family when dealing with purchases online. Just never. I’ll offer to pay the 3% tax instead. 
     

    If you get screwed PayPal won’t do anything.

    Link

    UnfortunateCookie
    Participant
    Member
    France
    Accuracy: +0

    Ok that was impressive. I can’t imagine doing this. Never tryed though ! I’m happy to get good groups at 50yards!

    Link

    UnfortunateCookie
    Participant
    Member
    France
    Accuracy: +0

    Tryed everything. Safety is working when I remove the stock but when I install it back, it’s not. Even worse now while adjusting the grub screw on the trigger, forgot that the gun was cocked and it dry fired. Long story short I heard the air remaining in the tube going off.

    Argh this is driving me mad. I sent a mail to FX support they told me I can order the replacing part from said retailer.

     

    Ok … at this point I just don’t want to touch it any longer. I’m a casual airgunner I know those guns are fragile and this is why in the first place I didn’t want to tinker with it and break something.

    Now I’m left with a gun malfunctioning. Don’t know what to do next. Hitting a wall here. 
     

    Thanks you guys for being helpful.

    Link

    UnfortunateCookie
    Participant
    Member
    France
    Accuracy: +0

    Thanks for the link. Tryed everything. Safety seemed to work when I removed the stock but  once I install it back, safety still not working.

    Also there is no « click » sound when I action the safety lever.

    I’ll contact FX support I guess … this is too dangerous. And the retailer so far just sent me YouTube video and schematics which helped but it’s not working.

Viewing 4 posts - 1 through 4 (of 4 total)